The Managed NetSuite Plug-In is Not Holding Orders with a 233 Reason Code
A custom reason code must be created to hold the different 233 Reason Codes within the NetSuite plug-in.
KA-07083
6
10/24/2024 21:51 PM
1.0
Problem Description
When utilizing the Transaction Hold Reason functionality of the managed plug-in, certain orders rejected with reason code 233 are not put into a hold status within NetSuite.
Cause
For declines with a 233 reason code, there are some response messages from processors that are not recognized by the bundle. As a result, the integration will not place an order receiving these response messages on hold.
Resolution
You need to add a custom response code to recognize the response message and place the order on hold.
First, identify the specific message received in the response by doing the following in NetSuite:
- Go to the transaction that wasn't placed on hold
- Select the Billing tab and select Payment Events
- Select View under View Details for the payment event
- Scroll down and select the Raw Response tab
- Locate the message: under the reason: PROCESSOR_ERROR
- Copy the message verbatim, including punctuation
- Example: Payment processor error PLEASE RETRY
- Example: Payment processor error PLEASE RETRY
Once you have identified the correct error message, add a custom response code by doing the following in NetSuite:
- Select Customization > Lists, Records & Fields > Record Types
- Find the API Response Code/Message record type and select New Record
- On the new API Response Code/Message record, enter:
- Name: 233 - PROCESSOR_ERROR
- Message: Enter the message that you copied from Step 6 above
- Example - Payment processor error PLEASE RETRY
- Save the new record
- In your Payment Processing Profile under HOLD TRANSACTION REASON CODES, the new reason code record is now visible 233 - PROCESSOR_ERROR
- Select the reason code to add it to your active list
- Save your Payment Processing Profile
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