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KA-07083


6

10/24/2024 21:51 PM

1.0

Problem Description

When utilizing the Transaction Hold Reason functionality of the managed plug-in, certain orders rejected with reason code 233 are not put into a hold status within NetSuite.

 

Cause

For declines with a 233 reason code, there are some response messages from processors that are not recognized by the bundle. As a result, the integration will not place an order receiving these response messages on hold.

 

Resolution

You need to add a custom response code to recognize the response message and place the order on hold.

First, identify the specific message received in the response by doing the following in NetSuite:

  1. Go to the transaction that wasn't placed on hold
  2. Select the Billing tab and select Payment Events
  3. Select View under View Details for the payment event
  4. Scroll down and select the Raw Response tab
  5. Locate the message: under the reason: PROCESSOR_ERROR
  6. Copy the message verbatim, including punctuation
    • Example: Payment processor error PLEASE RETRY

Once you have identified the correct error message, add a custom response code by doing the following in NetSuite:

  1. Select Customization > Lists, Records & Fields > Record Types
  2. Find the API Response Code/Message record type and select New Record
  3. On the new API Response Code/Message record, enter:
    • Name: 233 - PROCESSOR_ERROR
    • Message: Enter the message that you copied from Step 6 above
      • Example - Payment processor error PLEASE RETRY
  4. Save the new record
  5. In your Payment Processing Profile under HOLD TRANSACTION REASON CODES, the new reason code record is now visible 233 - PROCESSOR_ERROR
  6. Select the reason code to add it to your active list
  7. Save your Payment Processing Profile


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