Recurring Orders Are Failing Due to an Expired Card After Switching to the Managed NetSuite Plug-In
KA-05150
10
07/11/2024 22:01 PM
1.0
Problem Description
After switching to the managed NetSuite plug-in from the legacy integration, recurring orders are failing with errors related to an expired credit card.
Cause
This is due to the fact that legacy NetSuite plugin would send a fake expiration date of 12/2099 for stored cards that had a lapsed expiration date. Our managed plugin does not send a fake expiration date and sends the actual date that is stored on the card in NetSuite.
As a result, recurring transactions using a stored card with a lapsed expiration date will fail.
Resolution
You will need to update the stored card in NetSuite with a valid expiration date.
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